CentrixPVP
Join 0 others at play.skybattle.netClick to copy!
Status
Not open for further replies.

mastertotoy

Member
Member
Aug 1, 2017
101
8
18
22
#1
hello guys why i can't join centrix but i'm in 1.8.9, and when im joining it always say that Please Use 1.12.2 but in the (like lore) icon, it says below it 1.8 can join and it have 14/2000 players :/


No one plays 1.12 above :D
 
Status
Not open for further replies.